python3.5.i cant install third-party libraries for python by using instructions “ python setup.py install” - python-3.5

When I tried to install third-party libraries for python3.5,something is wrong like that
E:\IE\pycocotools-2.0.0>python setup.py build
running build
running build_py
running build_ext
error: [WinError 2] The system cannot find the file specified
the setup.py is from:https://github.com/philferriere/cocoapi
and i want to install cocoAPI to use coco dataSets.
addtions:1 .i had installed vs2017(vc++ environment) in my computer

Related

Robot framework | jybot not recognized as internal or external command

While executing our robot framework scripts, we get error : "jybot is not recognized as internal or external command"
Steps followed for installation:
installed python and set path in environment variables
installed jython and set path in environment variables
installed robotframework using robotframework-2.9.1.win-amd64.exe
while installing robotframework only two files were created "pybot" ,"rebot" and "robot" . We created jybot .bat file and set path of run.py file created in python\lib\site-packages\robot folder
our application has build over java swing, so we have created one wrapper file in python. we have placed everything in jython folder and trying to execute test cases.
error while execution -- jybot is not recognized as internal or external command.
could you please suggest a solution to this issue
Most probably you have not installed robotframework to jython interpreter.
Verify this by checking list of packages in jython by pip:
jython -m pip list
or checking if robot is really installed:
jython -m robot.run
If there is no pip or no robotframework package in list:
install pip to jython (easist is to download get-pip.py from web and run jython get-pip.py)
run pip from jython and install robot:
jython -m pip install robotframework

Custom setup for Java dataflow on Google Cloud

In Python dataflows on GCP, it seems to be possible to specify your own setup.py to install pip dependencies and apt-get dependencies for your dataflow worker environment. Is this possible for Java dataflows?

How do I install package PyNetSim-1.0 from Anaconda3

I am new to Anaconda. I installed Anaconda3 to my system. I want to install PyNetSim package available from sourceforge. Read.txt in that package says install using 'python setup.py install' command. How do I run this command from spyder IPython console (IDE).

Python/Installing cvxpy package error - setup.py egg_info with error code 1

I'm trying to install cvxpy on my Mac through pip and through PyCharm and I'm getting the following error: "Command "python setup.py egg_info" failed with error code 1 in /private/tmp/pip-build-azdpOA/CVXcanon/". Would anyone know what's that and how to fix this?
My python is 2.7
My pip is 8.1.2
My PyCharm is 4.5.4
My OSX is 10.8.5
The module CVXcanon is a dependency by the official installation instructions.
We recommend using Anaconda rather than the Python that comes with the Mac and installing pip, nose, NumPy, SciPy, and CVXOPT through Anaconda (i.e., conda install pip nose numpy scipy cvxopt). But it is not necessary to have Anaconda to install CVXPY, and the instructions below assume you do not have Anaconda.
Install the command line tools xcode-select --install and then install the module with all dependencies pip install cvxpy. You can use the Terminal tab in PyCharm.

Unable to build yesod app: ``strip.exe: unable to rename``

I'm trying to build an application using Yesod on Windows. I installed the haskell platform, and then Yesod using cabal. The command yesod init works, but after installing the dependencies cabal exits with the following message:
Resolving dependencies...
Configuring yosog-0.0.0...
Building yosog-0.0.0...
Failed to install yosog-0.0.0
Last 10 lines of the build log ( C:\Users\dna\AppData\Roaming\cabal\logs\yosog-0.0.0.log ):
Installing library in
C:\Users\dna\AppData\Roaming\cabal\x86_64-windows-ghc-7.8.3\yosog-0.0.0
Installing executable(s) in C:\Users\dna\AppData\Roaming\cabal\bin
C:\Program Files\Haskell Platform\2014.2.0.0\mingw\bin\strip.exe: unable to rename 'C:\Users\dna\AppData\Roaming\cabal\bin\yosog.exe'; reason: File exists
cabal.exe: Error: some packages failed to install:
yosog-0.0.0 failed during the final install step. The exception was:
ExitFailure 1
Do you have any idea about what can be causing this error?
The version of the haskel platform I have installed ships with ghc 4.8.3, and cabal-install version 1.18.1.3 of the Cabal library.

Resources